نمایش نتایج: از 1 به 9 از 9
Like Tree5 لایک
  • 1 Post By tanha71
  • 1 Post By magmagmary
  • 1 Post By tanha71
  • 1 Post By magmagmary
  • 1 Post By tanha71

موضوع: راه اندازی میکرو atmega 2560 و تبدیل این میکرو به آردوینو مگا 2560

  1. #1
    Senior Member
    تاریخ عضویت
    Oct 2014
    محل سکونت
    ایران
    نوشته ها
    178

    راه اندازی میکرو atmega 2560 و تبدیل این میکرو به آردوینو مگا 2560

    بسم الله لرحمن الرحیم

    امروز تصمیم گرفتم دو عدد برد مگا بسازم . میکرو مگا 2560 خریدم و اونا را روی برد مبدل 100 پین هویه کردم. سپس بوت لدرarduino genuino or mega 2560 را روی این آی سی پروگرام کردم.
    الان میخواهم یک برنامه ساده مثلا چشمک زدن ساده روی این برد از طریق سریال بریزم ولی جواب نمیده!!!!مبدل pl2303 هست و برای ریست هم مدار بستم. کسی با این مشکل برخورد کرده؟!!!

    1.jpg
    درود بر کسانی که دعا دارند و ادعا ندارند
    نیایش دارند و نمایش ندارند
    حیا دارند و ریا ندارند
    رسم دارند و اسم ندارند…

  2. #2
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    بوت لودر موفقیت آمیز آپلود شد ؟
    done bootloading داد ؟

    اگر آره حالا باید مدار پروگرامینگ رو ببندید ؟
    پروگرام از طریق سریال انجام میشه

    شما به چه صورت مدار رو بستید ؟

  3. #3
    Senior Member
    تاریخ عضویت
    Oct 2014
    محل سکونت
    ایران
    نوشته ها
    178
    سلام. بله بوت لدر ریخته شد ولی سریال برنامه می ریزم جواب نمیده !!!انگار بوت لدر درست نیست.
    نمیدونم هنگم فعلا که بد حالم گرفته شد....
    حتی برنامه چشمک زن ساده را بدون بوت لدر هم ریختم ولی انگار ای سی فقط پروگرام میشه ولی برنامه را اجرا نمیکنه....
    مدارش سادس کریستال و خازن های 22 پیکوفاراد و اتصال AVCCو VCC ها به +5 و یه زمین هم به زمین و VRF هم با خازن به زمین متصل کردم...

    بوت لدر هم تمام و کمال بدون هیچ خطایی ریخته شد روش ولی بعد خواستم سریال برنامه بهش بدم برنامه را نمی ریزه.... نمیدونم دردش کجاس ... یه احتمال دادم ولی دیگه دیره... چون هردو میکرو را زدم داغون کردم.
    فکر میکنم مدار پروگرامر راب خواد.... نمیدونم
    من با مبدل CH340 خواستم سریال پروگرام کنم که نشد.
    لایک کردن
    درود بر کسانی که دعا دارند و ادعا ندارند
    نیایش دارند و نمایش ندارند
    حیا دارند و ریا ندارند
    رسم دارند و اسم ندارند…

  4. #4
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    نقل قول نوشته اصلی توسط tanha71 نمایش پست ها
    سلام. بله بوت لدر ریخته شد ولی سریال برنامه می ریزم جواب نمیده !!!انگار بوت لدر درست نیست.
    نمیدونم هنگم فعلا که بد حالم گرفته شد....
    حتی برنامه چشمک زن ساده را بدون بوت لدر هم ریختم ولی انگار ای سی فقط پروگرام میشه ولی برنامه را اجرا نمیکنه....
    مدارش سادس کریستال و خازن های 22 پیکوفاراد و اتصال AVCCو VCC ها به +5 و یه زمین هم به زمین و VRF هم با خازن به زمین متصل کردم...

    بوت لدر هم تمام و کمال بدون هیچ خطایی ریخته شد روش ولی بعد خواستم سریال برنامه بهش بدم برنامه را نمی ریزه.... نمیدونم دردش کجاس ... یه احتمال دادم ولی دیگه دیره... چون هردو میکرو را زدم داغون کردم.
    فکر میکنم مدار پروگرامر راب خواد.... نمیدونم
    من با مبدل CH340 خواستم سریال پروگرام کنم که نشد.

    اینجا یه مشکل مشابه مشکل شما داشتن
    ببینید میتونید حلش کنید ؟
    چون با 328 تست کردم ولی با 2560 تا حالا همچین تستی نکردم
    http://forum.arduino.cc/index.php?topic=380436.0
    لایک کردن

  5. #5
    Senior Member
    تاریخ عضویت
    Oct 2014
    محل سکونت
    ایران
    نوشته ها
    178
    ببخشید دیر جواب دادم... مدتی نبودم و حال خوبی ندارم...
    یکم این روز ها کم حوصله هستم. منم با 328 کلی تست کردم ولی مگا 2560 هم جواب داد ولی نمیدونم سریال چرا پروگرام قبول نمیکنه و حتی حالت عادی هم پروگرام میشه ولی برنامه اجرا نمیشه . فیوز بیت ها هم درست تنظیم کردم....
    ممنونم ازتون مطالعه می کنم شاید کارم ایراد داره 100 ...
    لایک کردن
    درود بر کسانی که دعا دارند و ادعا ندارند
    نیایش دارند و نمایش ندارند
    حیا دارند و ریا ندارند
    رسم دارند و اسم ندارند…

  6. #6
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    نقل قول نوشته اصلی توسط tanha71 نمایش پست ها
    ببخشید دیر جواب دادم... مدتی نبودم و حال خوبی ندارم...
    یکم این روز ها کم حوصله هستم. منم با 328 کلی تست کردم ولی مگا 2560 هم جواب داد ولی نمیدونم سریال چرا پروگرام قبول نمیکنه و حتی حالت عادی هم پروگرام میشه ولی برنامه اجرا نمیشه . فیوز بیت ها هم درست تنظیم کردم....
    ممنونم ازتون مطالعه می کنم شاید کارم ایراد داره 100 ...
    امیدوارم همیشه خوب و سرحال باشید .
    بله مطالعه بفرمایید اگر کمکی ازمون بر اومد اطلاع بدید
    لایک کردن

  7. #7
    Senior Member
    تاریخ عضویت
    Oct 2014
    محل سکونت
    ایران
    نوشته ها
    178
    ممنونم از لطف شما
    لایک کردن
    درود بر کسانی که دعا دارند و ادعا ندارند
    نیایش دارند و نمایش ندارند
    حیا دارند و ریا ندارند
    رسم دارند و اسم ندارند…

  8. #8
    Junior Member
    تاریخ عضویت
    Oct 2016
    نوشته ها
    1
    با سلام نحوه پروگرام کردن astmega2560 رو کسی می تونه توصیح بده در واقع ریختن بوت لودر درون این آی سی به چه صورت می باشد.. با تشکر

  9. #9
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    نقل قول نوشته اصلی توسط turajarmin نمایش پست ها
    با سلام نحوه پروگرام کردن astmega2560 رو کسی می تونه توصیح بده در واقع ریختن بوت لودر درون این آی سی به چه صورت می باشد.. با تشکر

    این موضوع دیتای زیادی تو اینترنت داره
    کافیه کلید واژه arduino burn bootloader atmega2560 رو سرچ کنید . نمونه ای از نتایج :

    https://kevinfundarek.wordpress.com/...e-arduino-ide/

    البته این در صورتیه که منظورت خود آی سی astmega2560 بوده باشه

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •  

SEO by vBSEO