صفحه 1 از 2 12 آخرینآخرین
نمایش نتایج: از 1 به 10 از 18
Like Tree7 لایک

موضوع: مشکل با ماژول sim800l

  1. #1
    Junior Member
    تاریخ عضویت
    Mar 2016
    نوشته ها
    17

    مشکل با ماژول sim800l

    سلام خدمت دوستان
    من این ماژول رو خریداری کردم ولی هر چی سعی میکنم تا باهاش ارتباط برقرا کنم موفق نمیشم

    به تغذیه ماژول یه باتری لیتیومی 3.7 ولت وصل کردم و پایه های rx , tx هم به آردوینو uno و وقتی دستور AT رو میفرستم هیچ جوابی از ماژول دریافت نمیکنم

    مشکل از کجاست؟!
    خیلی ممنون

  2. #2
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    4,024
    لطفا با این آموزش کامند بفرستید

    جلسه بیست و سوم : ارسال AT Command | وبلاگ آردوینو

    فقط این که ولتاژ 4.2 بالاتر بهش ندید

  3. #3
    Junior Member
    تاریخ عضویت
    Mar 2016
    نوشته ها
    17
    خیلی ممنون
    طبق آموزش پیش رفتم و وقتی دستور at رو میفرستم حروف ناخوانا از طرف ماژول ارسال میشه(مثل iÿ)
    فک کنم مشکل از تغذیه ماژول هست. درسته؟

  4. #4
    مدیر ویژه
    تاریخ عضویت
    Mar 2014
    نوشته ها
    586
    سلام باد ریتت بذار 115200 ...

  5. #5
    Junior Member
    تاریخ عضویت
    Mar 2016
    نوشته ها
    17
    روی همین باد گذاشته بودم ، روی بقیه باد ها هم تست کردم ولی مشکل حل نشد
    ویرایش توسط amir.h : 05-22-2016 در ساعت 07:18 AM

  6. #6
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    4,024
    نقل قول نوشته اصلی توسط amir.h نمایش پست ها
    خیلی ممنون
    طبق آموزش پیش رفتم و وقتی دستور at رو میفرستم حروف ناخوانا از طرف ماژول ارسال میشه(مثل iÿ)
    فک کنم مشکل از تغذیه ماژول هست. درسته؟

    نه
    baude rate تنظیم نیست
    دقت کنید baude rate کد و کنسول یکی باشه
    لایک کردن

  7. #7
    مدیر ویژه
    تاریخ عضویت
    Mar 2014
    نوشته ها
    586
    شاید نسخه قدیمیش دستت رسیده
    اینکار که میگم بکن منم اوایل همین مشکل داشتم بالاخره حل شد ...
    اول سیم کارت از روی ماژولت بردار تا راحت روشن شه ... بنده خدا
    یک حلقه بساز و دایم AT بفرست و چک کن ببین OK یا O یا K میگیری یا نه.به محض دریافت یکی ازین کاراکتر ها از حلقه خارج شو فرمان:
    AT+IPR=9600 فرست.
    بعدش
    AT&W
    به این ترتیب در حلقه AT که میفرستی اتوبادریت SIM800 بالاخره با AT ارسال مچ میشه.
    ضمنن میکروکنترلرت کریستال خارجی داشته باشه و روش کانفیگ شده باشه تا اسیلاتورش بادریت مناسب تولید کنه
    لایک کردن

  8. #8
    Junior Member
    تاریخ عضویت
    Mar 2016
    نوشته ها
    17
    نقل قول نوشته اصلی توسط magmagmary نمایش پست ها
    نه
    baude rate تنظیم نیست
    دقت کنید baude rate کد و کنسول یکی باشه
    مشکل از این قسمت نیست
    با چند ماژول دیگه هم ارتباط سریال برقرار کرده بودم و با اونها مشکلی نداشتم

    نقل قول نوشته اصلی توسط shobeir90 نمایش پست ها
    شاید نسخه قدیمیش دستت رسیده
    اینکار که میگم بکن منم اوایل همین مشکل داشتم بالاخره حل شد ...
    اول سیم کارت از روی ماژولت بردار تا راحت روشن شه ... بنده خدا
    یک حلقه بساز و دایم at بفرست و چک کن ببین ok یا o یا k میگیری یا نه.به محض دریافت یکی ازین کاراکتر ها از حلقه خارج شو فرمان:
    At+ipr=9600 فرست.
    بعدش
    at&w
    به این ترتیب در حلقه at که میفرستی اتوبادریت sim800 بالاخره با at ارسال مچ میشه.
    ضمنن میکروکنترلرت کریستال خارجی داشته باشه و روش کانفیگ شده باشه تا اسیلاتورش بادریت مناسب تولید کنه
    این کار هم کردم ولی همون دو حرف که گفتم میومد ÿi هر چند وقتی یه تغییر میکرد مثلا میشد ÿé ولی هیچ کدوم از اون حروفی که شما گفتید، نشد

    ماژو خراب نیست آیا؟!
    ویرایش توسط amir.h : 05-27-2016 در ساعت 09:17 AM

  9. #9
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    4,024
    نقل قول نوشته اصلی توسط amir.h نمایش پست ها
    مشکل از این قسمت نیست
    با چند ماژول دیگه هم ارتباط سریال برقرار کرده بودم و با اونها مشکلی نداشتم



    این کار هم کردم ولی همون دو حرف که گفتم میومد ÿi هر چند وقتی یه تغییر میکرد مثلا میشد ÿé ولی هیچ کدوم از اون حروفی که شما گفتید، نشد

    ماژو خراب نیست آیا؟!
    اگه هر دو کاری که کفتیم نشده یه کم قضیه متفاوت می شه

    چون کامند AT دقیقا برای تست داده میشه
    از یه طرف هم داره به ازای هر At که شما می فرستی یه چیزی بر می گردونه ( هر چند خرچنگ غورباقه )
    ترجیحا ولتاژ 4.2 هم بده

  10. #10
    Junior Member
    تاریخ عضویت
    Mar 2016
    نوشته ها
    17
    خیر فایده ای نداشت
    فک نمیکردم انقدر دردسر داشته باشه این ماژول

صفحه 1 از 2 12 آخرینآخرین

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •  

SEO by vBSEO