نمایش نتایج: از 1 به 8 از 8

موضوع: مشکل با ماژول l298n

  1. #1
    Member
    تاریخ عضویت
    Jun 2016
    محل سکونت
    ایران عزیر
    نوشته ها
    74

    Question مشکل با ماژول l298n

    با عرض سلام و خسته نباشید.
    متاسفانه من این مشکل رو با ماژول L293D و L293B هم دارم.
    وقتی ماژول رو به موتورها وصل میکنم سرعت دو موتور تفاوت زیادی با هم داره.
    در صورتی که بین EN هردو یک هستش. و اینکه موتور ها مشکلی ندارن. چون به سر باتری وصل کردم و دیدم که هر دو با یه سرعت میچرخن. با چهار تا موتور دیگه هم تست کردم. بنظرتون مشکل از کجاست.؟؟؟؟؟

  2. #2
    Member
    تاریخ عضویت
    Jun 2016
    محل سکونت
    ایران عزیر
    نوشته ها
    74
    سلام. کسی جواب نمیده؟؟ من این ماژول رو گرفتم از اینجا.
    درایور Bipolar Stepper Motor - DC Motor دو کاناله L298N Dual H Bridge

    ماژول خرابه؟؟؟

  3. #3
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    نقل قول نوشته اصلی توسط poggije نمایش پست ها
    سلام. کسی جواب نمیده؟؟ من این ماژول رو گرفتم از اینجا.
    درایور Bipolar Stepper Motor - DC Motor دو کاناله L298N Dual H Bridge

    ماژول خرابه؟؟؟

    دوست عزیز به محض این که نتونستیم یه ماژول رو راه بندازیم که دلیل نمیشه خراب باشه . به خودتون انرژی منفی وارد نکنید.
    نحوه پاور دادنتون به این درایور به چه صورته ؟
    منظورتون از EN چیه ؟
    شما سرعت موتورهاتون رو با اون 4 پین آزاد باید تنظیم کنید.
    اگر با آردوینو کار می کنید اگر قصد دارید که موتورها با یه سرعت بچرخن باید analogWrite یه پین موتورها رو 0 بدید و analogWrite پین دوم هر موتور رو مقدار مساوی بین 0 تا 255 بدید.

  4. #4
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    توی این عکس شما باید به اون قسمتی که زده input وصل کنید به آردوینوتون و کد نویسی کنید.

    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: stepperConnections-600x600.jpg
مشاهده: 61
حجم: 93.1 کیلو بایت


    میتونید از کد اتچ شده هم استفاده کنید.
    یه مدل سیمب ندی هم ابه این صورته :
    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: 971f7e2abc2b63eb3ca4851be38a41e8.jpg
مشاهده: 64
حجم: 49.5 کیلو بایت

    اینجا اومده پاور 12 ولت استفاده کرده و داده به پین 12 و گراند تغذیه
    از اونطرف هم داده به دو تا ازپینهای PWM آردوینو .
    فایل های پیوست شده فایل های پیوست شده
    • نوع فایل: zip L298N_2.zip (197.1 کیلو بایت, 17 مشاهده)

  5. #5
    Member
    تاریخ عضویت
    Jun 2016
    محل سکونت
    ایران عزیر
    نوشته ها
    74
    سلام. با تشکر از جوابتون.
    حقیقتش همه ی این کارهایی که شما گفتین رو انجام دادم. راستش با کلی ور رفتن با ماژول و امتحان کردم همه ی موارد فکر کردم که شاید اشکال از ماژوله. چون دو تا ماژول دارم و هر دو اینطورین. \س فک نکنم ماژول مشکلی داشته باشه.

    کاری که انجام دادم به این صورته:
    دو تا موتور گیربکس دار ۷۸۰ دور در دقیقه.
    قرمز یکی رو به InputA1 وصل کردم و از اردوینو یک کردمش. سیاه رو هم صفر کردم.
    قرمز اون یکی موتور رو هم به InputB1 وصل کردم و از اردوینو یک کردمش و سیاه رو هم صفر کردم.
    تا اینجای کار که عین همونجوری هست که شما گفتین. حالا وقتی ENA و ENB رو به \ین PWM وصل میکنم و هر دو رو مثلا ۸۰ قرار بدم. سرعت یکی از موتور ها کمتر از اون یکی هستش. با اعداد مختلف هم تست کردم.
    وقتی سرعت موتور ها کم باشه معلوم میکنه سرعت ها با هم متفاوته. اگه EN ها رو ۲۵۵ بدم معلوم نمیشه که سرعت متفاوته.
    اگه نتونستم خوب توضیح بدم بگین تا ویدپوشو بزارم.
    در ضمن ورودی ماژول هم به باتری ۱۲ ولت ۳ آمبر وصل هستش.

  6. #6
    Member
    تاریخ عضویت
    Jun 2016
    محل سکونت
    ایران عزیر
    نوشته ها
    74
    منظورم از EN همون بین های Enable هستش

  7. #7
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,933
    متوجه نمیشم دقیقا چکار کردید
    تصویر زیر رو ببینید:
    برای دیدن سایز بزرگ روی عکس کلیک کنید

نام: stepperConnections-600x600.jpg
مشاهده: 53
حجم: 80.9 کیلو بایت


    شما باید سیم های موتورتون رو به ترمینال های output متصل کنید.
    بعد از اون از قسمت input وصل کنید به آردوینو .
    کاری به پینهای EN نداشته باشید. اونها برای فعال کردن خروجی موتور مربوطه هستن و نباید جامپر رو شون رو بردارید.
    شما هر کاری که قراره انجام بدید باید روی پینهای input انجام بدید.

    یعنی اینکه برای هر موتور دو تا پین in میمونه دیگه ؟
    هر دوی این پنیها رو وصل می کنید به دو تا پین pwm آردوینو . بعد یکیش رو 0 می کنید که میشه گراند . یکیشو مثلا همون 820 می کنید.
    موتور دوم هم دقیقا به همی صورت

    فکر می کنم شما دارید به پین ENسیگنال آنالوگ می فرستید.

  8. #8
    Junior Member
    تاریخ عضویت
    Sep 2017
    نوشته ها
    2
    شما بايد جهت رو از طريق پين هاي In با صفر و يك بهش بدي براي تنظيم سرعت هم به پين هاي enable بايد pwm بدي

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •  

SEO by vBSEO