صفحه 1 از 2 12 آخرینآخرین
نمایش نتایج: از 1 به 10 از 11
Like Tree1 لایک

موضوع: MPU-6050 Accelerometer + Gyro

  1. #1
    Junior Member
    تاریخ عضویت
    Dec 2013
    نوشته ها
    4

    MPU-6050 Accelerometer + Gyro

    سلام به دوستان

    من سعی کردم این سیستم رو راهندازی کنم . تا حد زیادی هم پیش رفتم اما نتیجه نهایی رو نمتونم بیبینم .

    Arduino Playground - MPU-6050

    کد:
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 184, -484, 14992
    temperature: 29.635 degrees Celsius
    gyro x,y,z : 367, 220, -812, 
    
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 116, -364, 15056
    temperature: 29.635 degrees Celsius
    gyro x,y,z : 373, 226, -766, 
    
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 232, -432, 15100
    temperature: 29.682 degrees Celsius
    gyro x,y,z : 382, 232, -790, 
    
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 280, -468, 15136
    temperature: 29.635 degrees Celsius
    gyro x,y,z : 368, 211, -820, 
    
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 140, -432, 15108
    temperature: 29.588 degrees Celsius
    gyro x,y,z : 388, 203, -806, 
    
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 220, -464, 14920
    temperature: 29.541 degrees Celsius
    gyro x,y,z : 374, 196, -774, 
    
    MPU-6050
    Read accel, temp and gyro, error = 0
    accel x,y,z: 172, -440, 15100
    temperature: 29.588 degrees Celsius
    gyro x,y,z : 363, 200, -769,
    دارم و همچنین برای I2c هم


    کد:
    I2C Scanner
    Scanning...
    I2C device found at address 0x68  !
    done
    به همین ترتیب ... اما LED روی MPU-6050 حالت قرمز رو داره که نسبت به نمونه های که کار می کونه به حالت سبز ه ...

    البته با سیستم های دیگه هم کامپایل گرفتم اما کار نمی کنه ..... مثل این

    Gyroscopes and Accelerometers on a Chip | Geek Mom Projects

    مشکل دقیقا نمی دونم کجاست ... دستگاه آنو که کار میکنه و MPU-6050 هم خروجی I2c رو می ده.

    تنها چیزی که درست نیست رنگ LED روی MPU-6050 است ... ! که فکر میکنم بعد اپلود کد باید به رنگ سبز در بیاد.

    منتظره راهنمایی تون هستم ...

  2. #2
    مدیر اصلی
    تاریخ عضویت
    Aug 2012
    محل سکونت
    ایران
    نوشته ها
    440
    سلام
    اگر ماژول رو از فروشگاه آفتاب رایانه تهیه کردید احتمالا اون led نمایشگر پاور هست و رنگش هم بعیید می دونم تغییر کنه ، در ضمن با توجه به اینکه i2c اسکنر ماژول رو شناسایی می کنه تنها موردی که می باقی میمونه آدرس i2c هست که میبایست در کد اصلاح بشه، به توضیحات کد هم دقیت کنید همین مطلب قید شده

  3. #3
    Junior Member
    تاریخ عضویت
    Dec 2013
    نوشته ها
    4

    Question

    نقل قول نوشته اصلی توسط spark نمایش پست ها
    سلام
    اگر ماژول رو از فروشگاه آفتاب رایانه تهیه کردید احتمالا اون led نمایشگر پاور هست و رنگش هم بعیید می دونم تغییر کنه ، در ضمن با توجه به اینکه i2c اسکنر ماژول رو شناسایی می کنه تنها موردی که می باقی میمونه آدرس i2c هست که میبایست در کد اصلاح بشه، به توضیحات کد هم دقیت کنید همین مطلب قید شده

    ممنون از پاسخ شما ...

    آدرس دهی به احتمال زیاد اشتباه نیست . ولی نمی تونم به طور قطع هم بگم که هیچ مشکلی هم نداره .!

    نمونه ای که در این سایت است . کار می کنه ...

    Gyroscopes and Accelerometers on a Chip | Geek Mom Projects

    برای UNO

    http://www.geekmomprojects.com/?wpdm...d=Mi5ob3RsaW5r

    برای نمایش Processing

    http://www.geekmomprojects.com/?wpdm...d=My5ob3RsaW5r

    در قسمت پایین خروجی هم نمایش داده شده .. ولی ؟

    اگه میشه یه راهمایی در خصوص کدا به من بکنید . من تا جایی که میدونستم اصالح می کنم . اما نتیجه نهایی مهم که ، بهش نمیرسم .

  4. #4
    مدیر اصلی
    تاریخ عضویت
    Aug 2012
    محل سکونت
    ایران
    نوشته ها
    440
    سلام
    اگر با این کدهای جدید کار می کنه پس مشکل چی هست؟ چه نتیجه ای منظورتون هست؟

    این قسمت در کد مربوط آدرس I2c هست
    کد:
    // Default I2C address for the MPU-6050 is 0x68.
    // But only if the AD0 pin is low.
    // Some sensor boards have AD0 high, and the
    // I2C address thus becomes 0x69.
    #define MPU6050_I2C_ADDRESS 0x68

  5. #5
    Junior Member
    تاریخ عضویت
    Dec 2013
    نوشته ها
    4
    نقل قول نوشته اصلی توسط spark نمایش پست ها
    سلام
    اگر با این کدهای جدید کار می کنه پس مشکل چی هست؟ چه نتیجه ای منظورتون هست؟

    این قسمت در کد مربوط آدرس I2c هست
    کد:
    // Default I2C address for the MPU-6050 is 0x68.
    // But only if the AD0 pin is low.
    // Some sensor boards have AD0 high, and the
    // I2C address thus becomes 0x69.
    #define MPU6050_I2C_ADDRESS 0x68
    تشکر ی .. دوباره .

    منظور از نتیجه گیری اینه که بعد از کامپال گرفتن کدا در UNO و برای دیدن خروجی نهایی در Processing هیچ عملی صورت نمی گیره . یعنی در Processing هیچی نمی بینم .

    مهم تر از این که ، هم UNO کار می کنه هم GY-21 ، در نهایت این کدا باید مشکلی داشته باشن. در غیر اینصورت اولی باید مشکل داشته باشه !

    در Tube ها اکثر GY-21 به رنگ سبز روی برد هستند . فکر می کنم در حال پیش فرض رنگ قرمز باشن . اما بعد از کامپایل گرفتن باید به رنگ سبز در بیاد !؟.

  6. #6
    مدیر اصلی
    تاریخ عضویت
    Aug 2012
    محل سکونت
    ایران
    نوشته ها
    440
    سلام
    مورد برد ممکنه مشکل داشته باشه
    اکر برد رو از آفتاب رایانه تهیه کردید با همکارها در بخش فروش تماس بگیرید برای برگشت برد و انجام تست فنی ، اگر برد مشکل داشته باشه براتون تعویض می کنند.

  7. #7
    Junior Member
    تاریخ عضویت
    Dec 2013
    نوشته ها
    4
    نقل قول نوشته اصلی توسط spark نمایش پست ها
    سلام
    مورد برد ممکنه مشکل داشته باشه
    اکر برد رو از آفتاب رایانه تهیه کردید با همکارها در بخش فروش تماس بگیرید برای برگشت برد و انجام تست فنی ، اگر برد مشکل داشته باشه براتون تعویض می کنند.

    مشکل حل شد. و دستگاه کار میکنه .

  8. #8
    Junior Member
    تاریخ عضویت
    Feb 2014
    نوشته ها
    15
    سلام

    من هم با راه اندازی این برد مشکل دارم

    وقت compile کردن قایل این ارور رو میده

    i2cwrite was not declared inthis scope

    Arduino: 1.5.6-r2 (Windows 8), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

    MPU6050.ino:21:17: error: I2C.h: No such file or directory
    MPU6050.ino: In function 'void setup()':
    MPU6050:51: error: 'i2cWrite' was not declared in this scope
    MPU6050:52: error: 'i2cWrite' was not declared in this scope
    MPU6050:54: error: 'i2cRead' was not declared in this scope
    MPU6050:63: error: 'i2cRead' was not declared in this scope
    MPU6050.ino: In function 'void loop()':
    MPU6050:91: error: 'i2cRead' was not declared in this scope

    This report would have more information with
    "Show verbose output during compilation"
    enabled in File > Preferences.

    ممنون میشم راهتمایی بفزمایید
    فایل های پیوست شده فایل های پیوست شده
    • نوع فایل: zip IMU6DOF.zip (21.2 کیلو بایت, 17 مشاهده)

  9. #9
    مدیر اصلی
    تاریخ عضویت
    Aug 2012
    محل سکونت
    ایران
    نوشته ها
    440
    سلام
    این مشکل دقیقا مربوط به کد هست احتمالا Library مربوط به اون نصب نشده

  10. #10
    Junior Member
    تاریخ عضویت
    Feb 2014
    نوشته ها
    15
    نقل قول نوشته اصلی توسط spark نمایش پست ها
    سلام
    این مشکل دقیقا مربوط به کد هست احتمالا Library مربوط به اون نصب نشده
    سلام مجدد

    میخواستم اگه ممکته بیشتر راهنمایی کنید!

    ممنون میشم

صفحه 1 از 2 12 آخرینآخرین

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •  

SEO by vBSEO