نمایش نتایج: از 1 به 5 از 5
Like Tree1 لایک
  • 1 Post By solxsado

موضوع: خواهشا کمک کنید sim900

  1. #1
    Junior Member
    تاریخ عضویت
    Jul 2016
    محل سکونت
    مهد دلیران
    نوشته ها
    26

    خواهشا کمک کنید sim900

    سلام اساتید گرامی.
    من امروز یه SIM900 خریدم (عکسش رو گذاشتم) و به Arduino uno وصل کردم. سیم کارتشم بدون PIN هست و قفلش بازه. ولی LED های STAT و NET روشن نمیشن. یعنی من وقتی من دکمه پاور sim900 رو میگیرم نگه میدارم و ول میکنم یه لحظه روشن میشن و خاموش میشه.به این صورت که STAT روشن میشه و چند بار NET خاموش روشن میشه و بعد جفتش خاموش میشه. اینو ارسال میکنه به برنامه بعد خاموش میشه :
    کد:
    RDY
    
    +CFUN: 1
    
    +CPIN: READY
    
    
    Call Ready
    GND به GND آردوینو وصله
    VCC به 5v آردویند وصله
    TXD به 9
    RXD به 10
    اینم کد برنامه :
    کد:
    #include <SoftwareSerial.h>
    
    SoftwareSerial mySerial(9, 10);
    
    void setup() {
      // put your setup code here, to run once:
      mySerial.begin(9600);
      Serial.begin(9600);
      delay(100);
    }
    
    void loop() {
      // put your main code here, to run repeatedly:
      if(Serial.available()>0)
      {
        mySerial.println(Serial.readString());
      }
      if(mySerial.available()>0)
      {
        Serial.println(mySerial.readString());
      }
    }

    اینم عکس :

    img_20160708_165654.jpgimg_20160708_165700.jpg

    فقط خواهشا کمک کنید واقعا واجبه...
    ویرایش توسط pedram77 : 07-08-2016 در ساعت 12:59 PM

  2. #2
    Senior Member
    تاریخ عضویت
    Dec 2013
    محل سکونت
    ایران - شیراز
    نوشته ها
    213
    5 ولت آردوینو نمی تونه ماژول رو راه اندازی کنه و ماژول دائما ریست میشه.
    1. از آداپتور 5 ولت 2 آمپر استفاده کن (تا جایی که من می دونم ولتاژ تغذیه سیم 900 3.7 تا 4.5 ولته)
    2. بین آداپتور و ماژول یک خازن 16 ولت ، 470 میکرو فاراد به صورت مورازی وصل کن

  3. #3
    Junior Member
    تاریخ عضویت
    Jul 2016
    محل سکونت
    مهد دلیران
    نوشته ها
    26
    یه ترانس یک و نیم آمپری پیدا کردم (220:27) و با پل و خازن صافش کردم بعد از 7805 استفاده کردم و وصل کردم.خازنم وصل کردم. بازم نشد. حتما باید آداپتور باشه؟

  4. #4
    مدیر گروه
    تاریخ عضویت
    Nov 2013
    محل سکونت
    ایران
    نوشته ها
    3,995
    نقل قول نوشته اصلی توسط pedram77 نمایش پست ها
    یه ترانس یک و نیم آمپری پیدا کردم (220:27) و با پل و خازن صافش کردم بعد از 7805 استفاده کردم و وصل کردم.خازنم وصل کردم. بازم نشد. حتما باید آداپتور باشه؟
    طبق صحبت دوستمون موضوع دقیقا سر ولتاژه
    شما برو اونجایی که ازش ماژول رو خریدی اطلاعتشون رو بخون
    ببین ولتاژ کاریش رو چی نوشته
    اگه نوشته 4.2 که باید بری سراغ باتری لیتیوم تک سل آمپر آمپر حدود 2

    اگر هم نوشته 5 ولت می تونی از سوئیچ آداپتورهای 2 آمپری بازار استفاده کنی

    دقت کن آمپر باتری / سوئیچ اداپتورت باید بالا باشه

    اگر هم بخوای میتونی لینکش جایی که خریدی رو بزاری ببینم چند ولته!

  5. #5
    Senior Member
    تاریخ عضویت
    Dec 2013
    محل سکونت
    ایران - شیراز
    نوشته ها
    213
    SIM900 | SIMCom | smart machines, smart decision | simcom.ee
    3.2 تا 4.8 ولت
    منبع از منبع تغذیه DC به DC قابل تنظیم استفاده می کنم
    منبع تغذیه قابل تنظیم - ورودی 4 تا 40 ولت - خروجی 1.3 تا 37 ولت + نمایشگر ولتاژ / ولت متر

    ولتاژ پیشنهادی 4.4 تا 4.6 ولت
    لایک کردن

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •  

SEO by vBSEO